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The information given in this manual is verified in the correctness on the date of issue. The 
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about such revisions or changes. 
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Trademarks 
Unigraf and UCD are trademarks of Unigraf Oy. 

Windows® 8, Windows® 7 and Windows® XP are trademarks of Microsoft Inc. 

All other trademarks are properties of their respective owners. 

Limited Warranty 
Unigraf warrants its hardware products to be free from defects in workmanship and 
materials, under normal use and service, for twelve (12) months from the date of purchase 
from Unigraf or its authorized dealer. 

If the product proves defective within the warranty period, Unigraf will provide repair or 
replacement of the product. Unigraf shall have the whole discretion whether to repair or 
replace, and replacement product may be new or reconditioned. Replacement product shall 
be of equivalent or better specifications, relative to the defective product, but need not to be 
identical. Any product or part repaired by Unigraf pursuant to this warranty shall have a 
warranty period of not less than 90 days, from the date of such repair, irrespective of any 
earlier expiration of original warranty period. When Unigraf provides replacement, then the 
defective product becomes the property of Unigraf. 

Warranty service may be obtained by contacting Unigraf within the warranty period. 
Unigraf will provide instructions for returning the defective product. 

CE Mark 
UCD-1 and UCD-2 products meet the essential health and safety requirements, is in 
conformity with and the CE marking has been applied according to the relevant EU 
Directives using the relevant section of the corresponding standards and other normative 
documents. 
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 ABOUT THIS MANUAL 

Purpose 
This guide is the User Manual of  UCD-2 Vx1, USB-connected video capture units for use 
in a PC with Windows® 10, Windows® 8, Windows® 7 or Windows® XP operating 
system. 

The purpose of this guide is to 

 Provide an overview of the product and its features. 

 Provide instruction for the user on how to install the software and the drivers. 

 Introduce the HW features of the units. 

 Provide instructions for the user how use the UCD Viewer software. 

Product and Driver Version 
This manual explains features found in UCD-1/-2 Setup Software Package 1.6. Please 
consult Unigraf for differences or upgrades of previous versions.  

Please consult the Release Notes document in the installation package for details of the SW 
versions and changes to previous releases. 

Notes 
On certain sections of the manual, when important information or notification is given, text 
is formatted as follows. Please read these notes carefully. 

Note This text is an important note 
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 HARDWARE 
First, hardware properties for UCD-2 Vx1 device are described and later the device specific 
features are presented. 

 

Figure 1  UCD-2 device back panel 

 

Connectors 

USB 

USB 2.0 Hi-Speed standard type-B connector. There is no power draw from this connector. 

Power 
Switchcraft S761K external power connector.  

Pin Description 

1. Tip +5VDC 

2. Sleeve Ground 
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Sync Out, Sync In 

Synchronization output and synchronization input for master slave configuration of 
capturing multiple parallel channels. 

Pin Description 

1. Tip Signal 1 

2. Ring Signal 2 

3. Sleeve Ground 

Status LEDs 
LED operations of UCD devices are firmware dependent and subject to change excluding 
power good which is always available. Functions for each LED are described in the figure 
below. 

UCD-2 Vx1 

 

LED Description 

1, 3, 9, 11 On = V-by-One symbol lock 

2, 4, 10, 12 Flashing = FW running 

6, 8 On = Power good 

7 For chained devices: On = Master, Off = Slave 

5 Unused 

 

The table below shows the pin-out of one connector. Please refer to chapter Connecting 
Source Devices later in this document on allocating data to the two connectors. 

Channel A is for the data of ODD and Channel B of EVEN pixels. N/C = No Connection 

   50 GND Signal Ground 

   51 N/C N/C / Not in use 
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UCD-2 VX1 

 

V-by-One Inputs 
V-by-One inputs use 19 pin HDMI connectors. Connectors are described in detail in the 
figure below. 

 

The following table describes function of each pin for each connector. 

Pin number Connector 5 Connector 6 

1 Lane 8 + Lane 4 + 

2 Lane 8 shield / Ground Lane 4 shield / Ground 

3 Lane 8 - Lane 4 - 

4 Lane 7 + Lane 3 + 

5 Lane 7 shield / Ground Lane 3 shield / Ground 

6 Lane 7 - Lane 3 - 

7 Lane 6 + Lane 2 + 

8 Lane 6 shield / Ground Lane 2 shield / Ground 

9 Lane 6 - Lane 2 - 

10 Lane 5 + Lane 1 + 

11 Lane 5 shield / Ground Lane 1 shield / Ground 

12 Lane 5 - Lane 1 - 

13 Unconnected Unconnected 

14 Unconnected Unconnected 

15 Unconnected LOCKn 

16 Unconnected HTPDn 

17 Ground Ground 

18 Unconnected Unconnected 

19 Unconnected Unconnected 
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Capture Process 
UCD hardware blocks are described in the figure below. Simplified version of the capture 
process is described as follows: 

1. Set V-by-One color depth (6/8/10/12 bits /V-by-One byte mode) 

2. Choose the desired number of V-by-One lanes to be captured. 

3. Set color depth (8/16 bits) that is transferred over USB to PC. This setting affects data 
amount i.e. preview frame rate. It does not need to be the same as V-by-One color 
depth chosen in step 1. 

4.  Trigger capture start. 

5. Video frames are saved to memory until memory is full. 

6. Frames are readable one by one from the memory until memory is empty. 

7. To continue, go back to step 4. 
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Device chaining 
Two or more UCD-2s can be chained together for capturing more than 8 lanes. The 
connection is done with a synchronizing cable as shown in the figure below. Figure in the 
following page shows the intended V-by-One connections in a chained configuration. 

When chaining devices, please pay attention to the following: 

 Device chain must not form a ring. 

 Both ends of the cables should always be connected to a device. 

 All devices must be connected to the same computer via USB cables. 

 LOCKn and HTPDn must be connected to correct devices for reliable operation. 

 Please not that connecting the lanes incorrectly does not prevent capturing but will only 
affect visible video. 
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External Trigger 
An external trigger can be used to start video capture precisely at the right time. Connect 
the external trigger to the Sync IN input (See Fig. 9). The trigger should provide a 3.3V 
logical levels. Video capture can be started by either rising or falling edge. 

The input is internally pulled up (10k resistor) to 3.3V. It enables triggering the video 
capture manually with a push button that simply grounds the input. 

External trigger mode needs to be enabled by setting the option value 
UUCD_OPTION_EXT_TRIGGER to either EXT_TRIGGER_FALLING or 
EXT_TRIGGER_RISING. Setting the option to EXT_TRIGGER_NONE disables external 
trigger mode. 

Exactly like in free-run mode, the application should invoke UUCD_StartCapture() and 
then it can read frames by calling UUCD_GetFrame() until all the buffered frames are 
transferred to a PC. In external trigger mode, the first UUCD_GetFrame() call may take 
long time as it will be waiting for an external trigger to start video capture. Consider setting 
long enough timeout by calling SetOption() with 
UUCD_OPTION_FRAMEINFO_TIMEOUT parameter. 

If UCD-2 devices are chained, the master device propagates the trigger to all slave devices. 
All chained devices start video capture synchronously. 



  

12 
 

 UCD VIEWER 
Unigraf UCD Viewer software is the configuration and capture GUI for UCD-2 devices.  

System requirements 
The UCD Viewer application can be used in 32-bit and 64-bit editions of Windows XP, 
Windows Vista, Windows 7, Windows 8 and Windows 10.  

Installation 
UCD Viewer can be installed by running UCD Setup.exe. The installer will allow you to 
select the components used and configure the install locations. 

Device and Mode Selection 
When UCD Viewer is launched, you can first select the connected UCD device.  

 

In the following dialog you can select the signal mode that you want to use.  
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Preview Window 
When you click Start capture a window will open and show a preview of your captured 
content.  

 

You can align the size of the preview window to the content by right clicking on top of the 
window and selecting one of the fixed zoom factors 25% [Alt+1], 50% [Alt+2] or 
100% [Alt+3]. 

You can display the captured content in a borderless window by selecting Borderless 
Mode. You can also maximize the window on your desktop by selecting Maximize. 

Controls 

You can end the current session by selecting File > Stop Capture. 

You can select another capture device by selecting File > Close Device. From the dialog 
click the new capture device that you need to use. 

Saving 

 By selecting File > Save snapshot (Ctrl+S) you can capture and save individual frames. 
By selecting File > Save video sequence you can save a sequence of captured frames. 

Capture Format 

 You can select the capture image format from Tools > Options. The available formats are 
PPM (up to 16 bpc), BMP and JPG (8 bpc). 

In the same dialog you can also select the folder where the image files are stored. 
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UCD-2 Vx1 

Vx1 Basic Video Capture Configuration 
In the following window you can select the preferred Vx1 Capture Configuration settings. 
Vx1 Capture Configuration settings are described in the figure below. 
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Setting Descripiton 

Lane count 
Number of lanes to capture. For cascaded devices, it shows the total number of lanes for all 
devices. 

Capture color depth 
Selects input color-depth and capture color-depth. The preview display is always 24 bit true-
color, while saved file will have the requested color-depth. 

Section count Number of sections the frame is divided into. 

Color mapping Selects color-mapping mode. (Vx1 should always use JEIDA). 

Measurement Mode DE-only or Hsync-VSync based measurement 

Vx1 Lane mapping 

All zero means that default mapping is used (= No change of lane order). This feature can 
be used to correct a situation where the Vx1 lanes are mixed up for some reason.  For 
example,  if lanes 1 and 2 are reversed on the physical connector, enter 2 to the first edit 
box, and 1 to the second. 

External trigger Controls using external trigger mode, see 2.7 

Capture mode 

In real time mode, the internal UCD-2 device buffer memory is not used, it only stores one 
frame. the screen is updated with minimal delay but some frames might be lost due to 
limited USB2 band width. In the buffered mode, a sequence of frames is stored in the 
internal buffer memory and then transferred to the PC. There are no frame gaps in this 
sequence. There may be gaps between sequences. 

Lock Options Adjust the needed delay period based on product specifications. For the configuration rules, 
follow the table below. 

 

HTPDN: 
0 = Normal operation 
(Default) 
1 = HTPDn signal is 
forced low 
2 = HTPDn signal is 
forced high 
 

LOCKN 
0 = Normal operation 
(Default) 
1 = LOCKn signal is 
forced low 
2 = LOCKn signal is 
forced high 
3= LOCKn signal is 
forced low, and stays 
low, after "LOCKN 
delay" time has 
elapsed. Timer starts 
after HTPDn goes low 
internally in normal 
operation. Setting of 
"HTPDN" value does 
not affect this timer.  
 

LOCKN delay, us: 
Timer value in 
micro seconds to 
"LOCKN" option 3. 
Default is 42000 us. 

Video valid delay, us: 
Timer value in micro 
seconds after which valid 
video is received from 
source after LOCKn 
signal goes low. Setting 
"LOCKN" option 1 or 2 
does not prevent timer 
operation. Default is 
42000 us. 
 

 

After selecting the settings you can start the acquisition by pressing ‘Start Capture’ 
button. You can return to the configuration window by selecting “Stop Capture” from the 
“File” option in the main menu. To return to the device selection window, select “Close 
device” from the “File” option in the main menu. 
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When capture is in progress, single frame capture and frame-sequence capture features 
are available through the “ File” option in the main menu. Captured frames are stored in 
files according to the settings in “Tools” → “Options” dialog described in chapter 3.5. 

Internal pattern generator 
Settings are similar to those described in Vx1 Basic Video Capture Configuration. 

Timing Measurement 
In device operation mode, select Timing Measurement. 
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Settings are similar to those described in Vx1 Basic Video Capture Configuration. 

 

UCD Viewer tabs 

In Time Measurement mode UCD Viewer shows five tabs: Raw, Content, Frame, Clock, 
Time Stamp and General. 
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Raw 
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Content 

 

Frame 
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Clock 

 

Time Stamp 

 

General 
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APPENDIX A. PRODUCT SPECIFICATION 

UCD-2 Vx1 
Power Requirement  

Supply voltage +5VDC ±15% 

Supply current < 3A 

Performance  

25MB/s USB transfer, typical (root dependent) 

8 Lanes 

3.75Gb/s V-by-One data rate / Lane 

20MHz  ̶  75MHz Pixel clock / Lane @ 5 byte mode 

20MHz  ̶  85MHz Pixel clock / Lane @ 4 byte mode 

20MHz  ̶  100MHz Pixel clock / Lane @ 3 byte mode 

Operating Environment  

Operation temperature +10°C  ̶  +40°C 

Storage temperature +0°C  ̶  +60°C 

 

Frame Buffering  

256 Frames 16.77 MPixels  Memory / Lane 

Buffering Examples 

Video Mode Lanes Buffered Frames 

1920×1080 @ 60Hz 2 16 

1920×1080 @ 60Hz 4 32 

1920×1080 @ 240Hz 8 64 

4096×2160 @ 60Hz 8 15 

4096×2160 @ 120Hz 16 (chained) 30 

 

All specifications are subject to change without notice. 
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APPENDIX C: PHYSICAL DIMENSIONS 
All UCD devices have lightweight aluminum casing with plastic rims. All lengths are given 
in mm. 

UCD-2 Vx1 
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