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QUICK START GUIDE 
This is a reduced version of the CTS tool configuration. If you feel quite confident with 
installing new hardware and software in your PC you can attempt this procedure. 

Serial Communication Setup 
 Copy dpcrefsinkgui.exe into your PC 

 If you are using a UFG-04 DP as the Test Equipment (TE), plug a COM port of your PC 
to the SubD 9 connector located on the back panel of the UFG. 

 If, instead, you are using a DPR-100, plug its USB connector to one of your PC USB 
ports. 

 Note the COM port that your PC is using for the communication with the Test 
Equipment (for instance from the Windows Device Manager). 

 Power up the TE. 

 Launch the tool 

 Use Tools > Options and in the dialog select the COM port that your PC is using. 

Verifying the Firmware Version 
 From the pull down menu select Tools > Firmware Update …  

 Click the Check Running Version to verify the version number of the firmware loaded 
in your Test Equipment. 

 If you need to upgrade the firmware select the new *.hex file and click Upgrade. 

 After the upgrade is complete reset the Test Equipment. 

Adding a License Key 
 Select Tools > Add License(s).  

 Insert each of the 32 character long License Keys in the field provided and click Add 
License button.  
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1. GENERAL 

About This Manual 
This guide introduces you the installation and use of Unigraf DP RefSink CTS Tool. 
Please refer to a relevant VESA standard for the description of the requirements and 
pass criteria for each test. 

The purpose of this guide is to 

• Give an overview of this Unigraf DP RefSink CTS Tool and its features. 
• Provide instructions for the user on how to install the tool and upgrade 

the Test Equipment firmware. 
• Guide to the tool practical usage. 

Product Versions 
This manual introduces functions in the following software versions. Please contact 
Unigraf for details.  

 Version Issued 
UGDP RefSink  release 2.1.0 7 Oct 2008 

Firmware (FW) UGDPSink_2.1.0.hex  
User Interface (GUI) dprefsinkgui.exe v.1.1.34  

Notes 
On certain sections of the manual, when important information or notification is given, 
text is formatted as follows. Please read these notes carefully. 

Note This text is an important note 
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2. INTRODUCTION 

Unigraf UFG 
UFG is a family of PCI bus frame grabber cards for capturing analog RGB, digital DVI 
and LVDS video and DisplayPort™ signal. The UFG family frame grabbers are widely 
used for analysis of various image sources. The DisplayPort™ CTS Tools are an 
optional feature for UFG-04 DP, a PCIe bus DP Reference Sink frame grabber. 

Unigraf DPR-100 
The DPR-100 is a compact sized yet full featured DisplayPort Reference Sink. It is 
controlled and powered by a PC through a USB connection. 

Unigraf UFG-04 DP 
The UFG-04 DP is a PCIe bus DisplayPort frame grabber, capable to capture and 
display full-resolution video on a PC, but also to operate as a DisplayPort Reference 
Sink. 

Unigraf DisplayPort™ CTS Tools 
The CTS tools consist of two components: the Windows graphical user interface (GUI) 
application, and the target firmware (FW) for the DisplayPort™ controller located on 
the Test Equipment (TE). The actual tests are implemented by the FW, while system 
control and status reporting are done by the GUI. The GUI and the FW are 
communicating using a serial interface. The FW implements both the functions needed 
in the CTS tests and the normal functionality as DP video generator or frame grabber. 

Unigraf’s DisplayPort™ Reference Source CTS can be used with the DP Video Test 
Generator VTG-5225-DP while the Reference Sink CTS can be operated on either the 
DPR-100 DP sink or the UFG04-DP DP Frame Grabber. 

Both CTS tools feature a graphical user interface that provides the user diagnostic 
functionalities and controls for performing the actual tests. The tools can generate 
detailed HTML test reports and may include both Link Layer and HDCP compliance 
tests.  
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Unigraf Reference Sink CTS Tool 
Unigraf’s Reference Sink CTS Tool can be used with either the DPR-100 or the 
UFG-04 DP frame grabber. The functionality of the CTS tool is identical between the 
two devices.  

The DPR-100 is connected to the PC by using an USB cable which also supplies power 
to it. The PC sees the DPR-100 as a virtual COM (RS-232) port, that is used to 
communicate with the CTS GUI. 

Conversely, the UFG-04 DP communicates with the CTS GUI using a genuine RS-232 
connection located on the back plane of the UFG board.  

Reference Sink Block Diagram 
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3. SETUP INSTRUCTIONS 

Contents of the Delivery 
Unigraf DP RefSink CTS Tool delivery includes the following items: 

• The Graphical User Interface (GUI) dprefsinkgui.exe  
• The DPRX Firmware (FW) UGDPSink_x.x.x.hex 
• Release notes UGDPRefSink_release_notes.txt 
• This manual 

Communications Setup 
DPR-100 unit includes an USB to serial conversion controller. Therefore it will be 
installed to Windows as a USB Serial Port. It is highly recommended to use the USB 
Serial Port driver provided in the DP RefSink CTS Tool delivery. 

Configuring the USB Serial Port for the DPR-100 
In order to install the driver please do the following. 

 Power up your PC 

 Copy the contents of the installation package into your PC. 

 Plug the DPR-100 to one of your PC USB port. 

 In the Welcome to the Found New Hardware Wizard dialog select No, not this time and 
click Next > 

 Select Install from a list or specific location and click Next > 

 Select Search for the best driver in these locations and click Browse to point to the 
Windows Drivers folder of the Installation Package. 

 The driver will now be installed in your PC. Click Finish to close the dialog 
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Identifying the serial port used 
The communication between the the CTS Tool GUI and the firmware located in the DP 
input card of the test equipment (TE) is done by using a serial communication (COM) 
port. The CTS tool will assign the right communication parameters (baud rate, stop bits, 
etc.) but you have to specify the COM port your PC is using for the connection. 

 Connect the UFG-04 DP to a COM port or the DPR-100 to a USB port of your PC. 

 Device Manager find out the COM port that Windows has assigned to the connection. 
When using a DPR-100 it will be the one marked as USB Serial Port.  

 
 Make a note of the COM port used as you will need to specify it in the GUI setup 

(following Chapter). 
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GUI Setup 
The CTS Tool graphical user interface (GUI) executable is named dpctsgui.exe. It can 
be copied to any location in your PC and does not require any special installation. You 
can run it directly from its folder by double clicking the icon. 

 

Setting up the Communication 
 From the pull down menu select Tools > Options … and select the serial port for 

communicating with the TE. In the Time-Out field you can define the maximum time a 
test can take for executing before it is aborted. In the Delay between tests field you can 
specify the time the tool will wait after a test has completed and before starting the 
following one. 
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Updating the TE Firmware 
The TE current firmware version can be verified and firmware can be updated by using 
the Firmware Upgrade dialog. 

 From the pull down menu select Tools > Firmware Update … . 

 Click the Check Running Version to check the current version number of the firmware 
(if needed). 

 Click the ellipsis button (…) to browse for a firmware update file and click Upgrade to 
start loading the code. You can monitor the status of the upgrade process from the 
Status panel in the lower part of the dialog. 

 After the upgrade is complete, press the Reset pushbutton on the DPR-100 or on the 
backpanel of the UFG04-DP. Click OK to return to the main dialog. 

 

Adding the License Code 
Unigraf CTS tools software are license protected. Each license is valid for one test 
equipment (TE) only. By using the CTS GUI you can read the Product Seed Number of 
the TE. For a given Seed Number, Unigraf will provide you a License Key that enables 
you to use the software in any number of PCs to control the given TE. 

 Open the License Manager from the pull down menu by selecting Tools > Add 
License(s).  

 Please provide Unigraf the Product Seed Number shown on the bottom of the dialog 
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 Insert each of the 32 character long License Keys in the field provided and click the 
Add License button. The license keys are now stored in your PC and you can 
constantly use the TE from this PC. Please Click Close to return to the main dialog. 

Note Please note that each DP RefSink CTS Tool software license is bound to one specific 
Unigraf Test Equipment (TE). Several licenses e.g. LL CTS and HDCP CTS can be in 
use at the same time. The same license can be used with any number of PCs when they 
are connected to the specific TE the license has been provided for. 

 
 

Note The License Key never includes characters I, G, B, O because of their similarity with 
the corresponding numbers. If doubt, please use numbers. You can use copy and paste 
to insert the License Code. 

 
 

Note The TE must be connected to your PC when entering the License Key. 
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4. USING THE CTS TOOL 
The user interface of Unigraf DP RefSink CTS Tool includes the following main 
functions: 

• Link Layer Tests, HDCP Tests or both 
• DPCD Access 
• Link Training status 
• Report generator 

The serial communication setup, firmware updates and license code entry are covered in 
section Setup Instructions of this manual. 

The following chapters describes the controls found in the five main dialogs. The report 
generator is described in its own section. The actual testing is described in chapter 
Running the CTS Test. 

Two Separate Parts 
Unigraf DP CTS tests are divided into two separate sets: DP Link Layer tests and DP 
HDCP tests. The license key can include one set or both sets combined. The following 
images show the structure of the tool tabs when only DP LL CTS tests are enabled and 
when both the DP LL and HDCP tests are enabled. 

Tool with only Link Layer tests enabled 

Tool with Link Layer and HDCP tests enabled 
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Status Panel 
You can follow the communication between the firmware in the TE and the test tool on 
the Status Panel on the lower part of the dialog. All executed test steps and reasons for 
Pass or Fail will be indicated here. The contents of the Status Panel will be copied also 
to the Test Report. You can clear the contents of the panel by clicking Clear Status. 
You can hide the panel by clicking the Hide Status. 

Note Please note that all of the executed test steps will be included in the report even if the 
Status Panel is cleared. 

Link Layer Tests Dialog 
For performing the Link Layer (LL) tests for Source DUT devices select the Link 
Layer Tests tab. 
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List of Tests 
The list of test on the right hand side of the dialog contains all of the DP LL CTS tests, 
indicating the corresponding chapter in VESA Link Layer Compliance Test Specification 
and the name of the test as it is mentioned in the specification. Place the mouse pointer 
on top of the name to see it in full. The Results Grid includes counters for: Pass, Fail, 
Skip, Timeout and a Status indicator.  

You can select a test either by clicking with the mouse or by moving up or down in the 
list with the Up and Down arrow keys in the keyboard. Home key selects the first test 
and End key the last test. You can select multiple consecutive tests by holding down the 
Shift key while selecting and multiple individual tests by holding the Ctrl key while 
selecting. 

Note Please note that pressing the pushbutton Clear Results will zero the result grid and also 
clear the content of the report from all previously performed tests. 

Test Control 
By using the test controls on the left side of the dialog you can Select All tests, Clear 
Results Grid of all tests, define how many times the Test Runs are repeated. Pressing 
Run Tests starts the selected test sequence and pressing the same key again Abort the 
sequence. 

DUT Capabilities 
Some of the tests require the Test Equipment to know about the capabilities of the DUT 
in terms of number of lanes supported, colorimetry available, etc. The list below 
describes the Source DUT capability fields that must be correctly filled by the CTS 
Tool operator before starting the tests. 

Fixed Timing 
If your DUT supports only one fixed timing, select the Fixed Timing checkbox. Then 
click Edit … to set the timing supported. 
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Colorimery Support 
To specify the Colorimetric values used during the testing click DUT Colorimetry 
Support  and in the dialog check the rows matching the Format, Bit Depth, Dynamic 
Range and Color Coefficient that you want to use. 

Max lane count 
The maximum lane count supported by the Source DUT. (1 Lane, 2 Lanes, or 4 Lanes) 

Max link rate 
The maximum link rate supported by the Source DUT. (Low 1.62 Gbps, or 2.7 Gbps) 

TEST_LINK_TRAINING 
Check if Test Automation TEST_LINK_TRAINING feature is supported. 

TEST_PATTERN 
Check if Test Automation TEST_PATTERN feature is supported. 

TEST_EDID_READ 
Check if Test Automation TEST_EDID_READ feature is supported. 

Video format change w/o LT 
Check if the DUT supports changes of video format without requiring a new Link 
Training. 

Lane # reduction w/o LT 
Check if the DUT supports lane number reduction (e.g. from 4 lanes to 2 lanes) without 
requiring a new Link Training. 

Power Save Mode 
Check if the DUT supports setting of the connected sink into Power Save mode. 

Drive level 3 (1.2 V) 
Check if the DUT supports a lane drive voltage of 1.2 V. 

Pre-emphasis level 3 (9.5 dB) 
Check if the DUT supports a lane pre-emphasis of 9.5 dB. 
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TA reset delay (after HPD=0) 
Set the time required by the DUT to acknowledge an unplug event and reset itself to a 
known state. This is the time the TE will keep the HPD signal de-asserted to simulate an 
unplug condition. 

TA req. delay (after HPD=1) 
Set the time required by the DUT to acknowledge a plug event and get ready to provide 
the required functionality. This is the time the TE will wait after asserting the HPD 
signal to simulate a plug condition, before proceeding with the ongoing test. 
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HDCP Tests Dialog 
For performing the HDCP CTS Tests for Source devices select the HDCP Tests tab. 

List of Tests 
The list of tests on the right side of the dialog contains all of the DP HDCT CTS tests 
for transmitter, indicating the corresponding chapter in VESA HDCP Compliance Test 
Specification and the name of the test as it is mentioned in the specification. Place the 
mouse cursor on top of the name to see it in full. The Results Grid includes counters for: 
Pass, Fail, Skip, Timeout and a Status indicator.  

You can select a test either by clicking with the mouse or by moving up or down in the 
list with the Up and Down arrow keys in the keyboard. Home key selects the first test 
and End key the last test. You can select multiple consecutive tests by holding down the 
Shift key while selecting and multiple individual tests by holding the Ctrl key while 
selecting. 

The HDCP Authentication Status indicator will turn green once a DUT source is 
connected and has HDCP authenticated correctly. 

Test Control 
By using the test controls on the left side of the dialog you can Select All tests, Clear 
Results Grid of all tests, define how many times the Test Runs are repeated. Pressing 
Run Tests starts the selected test sequence and pressing the same key again Abort the 
sequence. 
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DUT Capabilities 
Some of the HDCP tests require the Test Equipment to know about the capabilities of 
the DUT in terms of its HDCP support. The list below describes the Source DUT 
capability fields that must be correctly filled by the CTS Tool operator before starting 
the tests. 

CP_IRQ used for R0’ read 
Check if the DUT wait for CP_IRQ before reading R0’. 

CP_IRQ used for READY read 
Check if the DUT wait for CP_IRQ before reading the READY flag.. 

Encryption enable bootstrapping 
Check if the DUT supports encryption enable bootstrapping. 
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Link Training Dialog 
In order to see the link training status select the Link Training tab. 

Click Update Status to show the result of the previous Training  

Source / Sink Status 
The panel shows the link configuration negotiated by the Sink and the Source during the 
Link Training. Please refer to VESA DisplayPort Specification for a description of the 
parameters reported. 
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DPCD Read / Write 
DPCD Read / Write dialog enables you to read and write the content of the TE device 
DisplayPort™ Configuration Data registers (DPCD). From the pull down menu select 
Tools > DPCD Access ….  

Write the address of the DPCD register in field Source / Target Address:. For reading 
the register contents click Read. For modifying the register contents write the new 
value to field Data: and click Write. For returning to the main dialog, click Close.  

Please note that the DPCD register address and data and the contents are written and 
given in hexadecimal notation. E.g. “206” means 0x206. 
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5. TEST REPORT 
The tool includes a report generator that creates a test report of the results displayed in 
the Results Grid. The report is generated in HTML format and includes a detailed 
description of the test steps executed, the actions taken and the causes of the pass or 
failure. You can also include detailed description of the DUT and the used TE in the 
report. 

Note Please note that by clearing the Result Grid, you will clear also the Test Report  

Creating a Test Report 
For creating a report select from the pull down menu File > Save Report ….  

The Additional Data for Report dialog provides you fields for entering the reference 
data of the TE and the DUT that will be included in the report. The left column is for 
DUT data and the right column for the TE. 

In the Additional Comments field you can add more notes that will be included in the 
report. This could be remarks of the testing situation etc. 

Save the report by clicking Save Report or return to the main dialog without saving by 
clicking Cancel. The report will be saved to the path and file name specified at the 
bottom of the dialog. After the report is saved, your default internet browser will be 
opened to display the report file created. 

The information entered in the fields of the Additional Data for Report dialog will be 
available also for the following reports until the tool is closed. 
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Test Report Views 
Your internet browser will first open the report in the Test Summary view. This view 
provides you a test summary similar  to the one shown on the Sink Tests tab of the CTS 
tool. It summarizes all performed tests and their Pass, Fail, Time out or Skipped 
counters. The background of the status list is coloured red if the test never scored a Pass 

result. 

The Contents bar on the left side of the report is an active quick selection toolbar for 
showing the five (5) views of the report. 

Click Test Summary to get back to the initial view. 

Click General Information to show the information given on the Additional Data for 
Report dialog.  

Click View all test details to show all information for the progress and results of all 
tests. 

The Contents bar also contains a list of active links for showing the detailed results by 
test. Click one of the tests listed under View details by test to show the details if one 
test at a time. You can select this view also by clicking one of the test titles in the Test 
Summaryview. 

Click Printer Friendly for formatting the report for printing. 
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General Information View 
This view provides only the data from Additional Data for Report dialog 

All Test Details View 
This view provides the detailed procedures of the test and test result description for all 
the performed tests. The horizontal title bar of every test indicates the status of the test. 
Green if passed, Red if not passed. 
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Details by Test View 
This view provides the same information as the All test details view but only for the 
selected test. 

Printer Friendly View 
This view will remove the side toolbar and includes the General Information and All 
Test Details into one report for printing. To get back to the Test Summary View click the 
Back button of your internet browser. 
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6. USER INPUT DURING TESTING 
Depending on the capabilities of the DUT Source Device the operator might need to act 
manually on the DUT in order to perform certain tests. In that event, the test sequence 
will pause and wait for the operator confirmation that the DUT is ready. 

Below are listed two typical examples of the requests issued to the operator during test 
execution. 

The operator must force the DUT to read the whole EDID block within 5 seconds after 
pressing “Proceed”. 

The operator must force the DUT to start Link Training with the parameters indicated 
within 5 seconds after pressing “Proceed”. 

 


